Partstech Degraded Product Performance

Incident Report for Shop-Ware

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 13:35 PDT

Investigating

Our partner, PartsTech, is experiencing a product performance issue affecting our PartsTech integration for some users. We are working with PartsTech to help resolve it.
We’ll provide an update on this issue no later than September 23rd at 3 pm ET.
Posted Sep 23, 2025 - 08:41 PDT
This incident affected: Parts Ordering (PartsTech).