PartsTech is experiencing a degradation of service to their Vin decoder mechanism. Status update here: https://partstech.my.site.com/help/s/article/System-Status
Incident Report for Shop-Ware
Resolved
For continued updates on the PartsTech status, please review their status site: https://partstech.my.site.com/help/s/article/System-Status
Posted Feb 21, 2024 - 14:22 PST
Identified
PartsTech is experiencing a degradation of service to their Vin decoder mechanism. Status update here: https://partstech.my.site.com/help/s/article/System-Status
Posted Feb 21, 2024 - 11:01 PST
This incident affected: Parts Ordering (PartsTech).