investigating: can't print or save an RO
Incident Report for Shop-Ware
Postmortem

Time: 3/29/2023 from apx. 1:25 PST to 3:30 PST

Reported issues: users reported the inability to print an RO or save a PDF version of the RO. Users also reported an inability to load or use Messenger.

Postmortem:

Google released an update and introduced a bug which affected portions of our service. After our engineering team identified the issue, they temporarily disabled the “Google maps” library within our service. This has restored shops' ability to print an RO, save a PDF of the RO, and load Messenger. However, the "customer address auto complete" function within Shop-Ware is temporarily disabled. This means addresses won’t be “automatically looked up” as they are typed in. A permanent fix is expected to be released tomorrow (3/30/2023) which will fully restore Shop-Ware services back to normal (with the "customer address auto complete" function).

Posted Mar 29, 2023 - 15:56 PDT

Resolved
Engineering has identified the issue and implemented a fix.
Posted Mar 29, 2023 - 15:46 PDT
Investigating
We are currently investigating an issue which prevents the RO from being printed or saved.
The same issue may also be preventing "Messenger" from loading correctly.
Posted Mar 29, 2023 - 14:14 PDT
This incident affected: Web Application.