The integration interruption with Mitchell1/Prodemand has now been resolved, and the program is functioning normally for all users. If you’re continuing to experience issues, please feel free to reach out to our support team at support@shop-ware.com or by calling (415)890-0906.
Posted Oct 03, 2025 - 10:12 PDT
Monitoring
Mitchell1 is recovering and access has resumed for most requests, although there may be short delay.
Posted Oct 03, 2025 - 10:04 PDT
Identified
Our partner, Mitchell1/Prodemand, is experiencing a product performance issue, affecting some of our users. We are working with them to help resolve it. We’ll provide an update on this issue no later than tomorrow, October 4th at 11 am ET. If you have any questions or need support, please feel free to reach out to our support team at support@shop-ware.com or by calling (415)890-0906. For updates, please follow our status page: https://status.shop-ware.com/