PartsTech eComm unresponsive
Incident Report for Shop-Ware
Resolved
This incident has been resolved.
Posted Apr 12, 2023 - 10:42 PDT
Investigating
We are currently working with the PartsTech support team who is investigating their current outage. We will provide updates are they are received.
Posted Apr 12, 2023 - 10:36 PDT
This incident affected: Parts Ordering (PartsTech).