Slowdown with our partner, WORLDPAC’s e-commerce page.

Incident Report for Shop-Ware

Resolved

Update: WORLDPAC e-commerce performance has been restored.
The earlier slowdown affecting parts ordering through their portal has been resolved. We appreciate your patience as their team worked to address the issue, and we’ll continue to monitor performance in case anything changes.
Posted Jun 20, 2025 - 08:10 PDT

Identified

We’re currently observing a significant slowdown with our partner, WORLDPAC’s e-commerce page.
This may impact some users’ ability to order parts through that portal. We’ve reached out to WORLDPAC to see how we can support or provide a workaround while they resolve the issue.
We’ll keep you updated as we learn more. Thanks for your patience!
Posted Jun 20, 2025 - 07:17 PDT
This incident affected: Parts Ordering (WORLDPAC SpeedDIAL).